summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-21 16:54:32 +0000
committerSam James <sam@gentoo.org>2023-02-21 17:05:51 +0000
commit6f4fd01ce77707f7fd12245e12e5273096759558 (patch)
treee56974941595c2c999d71a2db62c25eee8b5296a /dev-python/flask-paginate
parentdev-python/flask-paginate: enable py3.11 (diff)
downloadgentoo-6f4fd01ce77707f7fd12245e12e5273096759558.tar.gz
gentoo-6f4fd01ce77707f7fd12245e12e5273096759558.tar.bz2
gentoo-6f4fd01ce77707f7fd12245e12e5273096759558.zip
dev-python/flask-paginate: PEP517, github distfile name
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2022.1.8-r1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 5ad426857435..1379e0be6bb9 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
+DIST flask-paginate-2022.1.8.gh.tar.gz 120847 BLAKE2B 110d6f7bb6c244378a41ab26c914898b54fb05cc00cfc6c7c3e15ed96e2163f92cc89c4ce93199091d8ed2f52301e997ebc16a71a3d802b8107249f9f832ca25 SHA512 9f2e0e50d73ac15ec2a413671a52e9dbbbb7eac8576494483441ea1287a12e2076cf649ee9df0bf3b3d2c7e13eebe4a835031ab57a2e8b2015f383d53318a0b9
DIST flask-paginate-2022.1.8.tar.gz 120847 BLAKE2B 110d6f7bb6c244378a41ab26c914898b54fb05cc00cfc6c7c3e15ed96e2163f92cc89c4ce93199091d8ed2f52301e997ebc16a71a3d802b8107249f9f832ca25 SHA512 9f2e0e50d73ac15ec2a413671a52e9dbbbb7eac8576494483441ea1287a12e2076cf649ee9df0bf3b3d2c7e13eebe4a835031ab57a2e8b2015f383d53318a0b9
diff --git a/dev-python/flask-paginate/flask-paginate-2022.1.8-r1.ebuild b/dev-python/flask-paginate/flask-paginate-2022.1.8-r1.ebuild
new file mode 100644
index 000000000000..bf6e520d55d0
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2022.1.8-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}