summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-11-03 17:12:39 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-11-03 23:59:06 +0100
commitfc06ad69f14424622012113166e4783c0a681d66 (patch)
tree41882fc4be7ed82facd674cb146433e8eeaec87f /dev-python/flask-paginate
parentsci-libs/gdal: Fix build with app-text/poppler-0.69.0 (diff)
downloadgentoo-fc06ad69f14424622012113166e4783c0a681d66.tar.gz
gentoo-fc06ad69f14424622012113166e4783c0a681d66.tar.bz2
gentoo-fc06ad69f14424622012113166e4783c0a681d66.zip
dev-python/flask-paginate: new package.
Signed-off-by: David Roman <davidroman96@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10331 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.1.ebuild24
-rw-r--r--dev-python/flask-paginate/metadata.xml19
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
new file mode 100644
index 000000000000..9b484e21a943
--- /dev/null
+++ b/dev-python/flask-paginate/Manifest
@@ -0,0 +1 @@
+DIST flask-paginate-0.5.1.tar.gz 5397 BLAKE2B 819740f6d1ff55331932dfb1a588fb0a92b2a6ffbf66c0ffcedddb2014c42c10f76ce50306fb9e389c66fdeba98fbf0d476915e935530bfeecc853ec25c1f9d4 SHA512 f17610cc3861d587e1940a69957a9266459270453d8f7c15ae6b6e5fa91633194e01384b1cec98647db70f38090d18fd44bf2fc4cbbd8d1d64cf541a5bd620c2
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.1.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.1.ebuild
new file mode 100644
index 000000000000..7b73a8c8fbef
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-paginate/metadata.xml b/dev-python/flask-paginate/metadata.xml
new file mode 100644
index 000000000000..35a30be0a275
--- /dev/null
+++ b/dev-python/flask-paginate/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lixxu/flask-paginate</remote-id>
+ </upstream>
+</pkgmetadata>