summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-24 16:04:48 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-24 16:08:09 -0700
commiteab31a577d813bc89e8c77fa800047ca3e1e442a (patch)
treebff9e23ea7695643bd37046cdae35fd0af6f8f6f /dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
parentdev-python/python-socketio: version bump to 1.8.0 (diff)
downloadgentoo-eab31a577d813bc89e8c77fa800047ca3e1e442a.tar.gz
gentoo-eab31a577d813bc89e8c77fa800047ca3e1e442a.tar.bz2
gentoo-eab31a577d813bc89e8c77fa800047ca3e1e442a.zip
dev-python/flask-socketio: version bump to 2.9.2
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/flask-socketio/flask-socketio-2.9.2.ebuild')
-rw-r--r--dev-python/flask-socketio/flask-socketio-2.9.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild b/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
new file mode 100644
index 000000000000..60880a0c55de
--- /dev/null
+++ b/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Flask-SocketIO"
+DESCRIPTION="Socket.IO integration for Flask applications."
+HOMEPAGE="https://flask-socketio.readthedocs.org/ https://github.com/miguelgrinberg/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-socketio-1.5.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH="${PWD}" python ./test_socketio.py || die
+}