summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-30 00:44:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-30 01:02:28 +0200
commit1a51ec000c28ba4173c034f922f95520b530ebc6 (patch)
tree78bd6ca6b33a02ab34bb8847c10864ef24c5c362 /dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
parentdev-python/flufl-lock: Bump to 5.1 (diff)
downloadgentoo-1a51ec000c28ba4173c034f922f95520b530ebc6.tar.gz
gentoo-1a51ec000c28ba4173c034f922f95520b530ebc6.tar.bz2
gentoo-1a51ec000c28ba4173c034f922f95520b530ebc6.zip
dev-python/flufl-i18n: Bump to 3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flufl-i18n/flufl-i18n-3.2.ebuild')
-rw-r--r--dev-python/flufl-i18n/flufl-i18n-3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild b/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
new file mode 100644
index 000000000000..bc9300e4f4e5
--- /dev/null
+++ b/dev-python/flufl-i18n/flufl-i18n-3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="A high level API for Python internationalization"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.i18n"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=flufl::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}