summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-13 07:37:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-13 07:51:08 +0200
commitf7d91f595e81450cfcf3ea93b01bd0cf510ec13a (patch)
treef4231122cccd959aff8685852898bf3b55046df2 /dev-python/fonttools
parentdev-python/hatchling: Bump to 1.18.0 (diff)
downloadgentoo-f7d91f595e81450cfcf3ea93b01bd0cf510ec13a.tar.gz
gentoo-f7d91f595e81450cfcf3ea93b01bd0cf510ec13a.tar.bz2
gentoo-f7d91f595e81450cfcf3ea93b01bd0cf510ec13a.zip
dev-python/fonttools: Bump to 4.40.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.40.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 4c83320404bd..ba6eddb89607 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1 +1,2 @@
DIST fonttools-4.39.4.gh.tar.gz 3710610 BLAKE2B f4d75ae71c7b8ec752eee3820129719583072c8e1e68d54b3443c192e7c6732e7db7adfaec32145b87eccd23b1720a748e70682d58a1628d93f89890d3ddc274 SHA512 4be7c19022ccfbb182edb7d80ec50ff2aa91eae3dd4328c1023e65a293e079edd4c1ae0a8b2260e35fa940417e7b03dc96bd7a6d6ec4234bc4c4257187b24758
+DIST fonttools-4.40.0.gh.tar.gz 3726926 BLAKE2B c14cf10baeca50f6a70dc210de40f46b24effa66efdaded0a2706539af659b7fea276064b352fbe2f412028912658dc3f215409c3975bd773a7bd789986a65a1 SHA512 03daecfb2c48e13f22255872dd9dca47aaca9fc71139f2d5876cdb74fa8560d697344845d870742da00d3734043e36f143efe5d2048b884a5f7ed924435aa2f0
diff --git a/dev-python/fonttools/fonttools-4.40.0.ebuild b/dev-python/fonttools/fonttools-4.40.0.ebuild
new file mode 100644
index 000000000000..317802fa12f7
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.40.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}