summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-08 17:34:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-08 18:02:33 +0100
commit6ba0da61fac0fcb6b1aeba84f89bda7853922c9e (patch)
treec0d1628be668f8b660e10a367eb2614c3aa7f84f /dev-python/fritzconnection
parentdev-python/identify: Bump to 2.5.19 (diff)
downloadgentoo-6ba0da61fac0fcb6b1aeba84f89bda7853922c9e.tar.gz
gentoo-6ba0da61fac0fcb6b1aeba84f89bda7853922c9e.tar.bz2
gentoo-6ba0da61fac0fcb6b1aeba84f89bda7853922c9e.zip
dev-python/fritzconnection: Bump to 1.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.12.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 87e076bd8211..6410a376b88a 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1,2 +1,3 @@
DIST fritzconnection-1.10.3.gh.tar.gz 146450 BLAKE2B 77c64d2963ed0bc1c1bf1d31fc42093d959588df5ea55956c2deb35c1569f76f1b89bb2f1273ad691285d21f168f5acdbb1326bcad4ed2e575d57b9a6187e839 SHA512 e54cf5ec4392c8bc0b6cbc19111819bd72125bf1eb341380686c0ac513c646dec16f8a243fdfbe22199c954cbf26c80ab30dbe93b5e02288bc25fcae28595305
DIST fritzconnection-1.11.0.gh.tar.gz 147539 BLAKE2B def880bcf80bb99864bca942b86c86adcda878fb62b7c0e35db4a746310e5ec8ad00bc25f43acac23c0d5410dc8790875b8b0822aa6d944a0e1197379e015e22 SHA512 bb517a63616a961f9c2c701d44093024f0763c093f89b99d205fb1fd1492342b568b871ebaf699a69a9d56e724735b975c48e4abd1780726d10c13e075cf08f2
+DIST fritzconnection-1.12.0.gh.tar.gz 156938 BLAKE2B 731715514036a965fa8c9cf8bb808459f22a0c6b2df171c105f1d12f070eae8d6a36a0e77e9a35a024585f682b7c84f2a486006e670655a3b16b043695c57818 SHA512 b743810a24d39be34910e233faae0061974de540e746e88b2f63c1f3d5536e9de684862b02738f969e294ae2b6044d0994e1b9317e6a723b5acf9540d2995c12
diff --git a/dev-python/fritzconnection/fritzconnection-1.12.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.12.0.ebuild
new file mode 100644
index 000000000000..c82f65f2406f
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+)
+
+src_prepare() {
+ # upstream is pinning for py3.6 compat x_x
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+ distutils-r1_src_prepare
+}