summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 06:51:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 06:53:07 +0100
commit7750a300134e9870e3a3ec97b2eac4e114293bb0 (patch)
treeed91e4cb9c3279a1bb2a82a4a39b7ddf486ed701 /dev-python/frozendict
parentdev-python/aws-sam-translator: Remove old (diff)
downloadgentoo-7750a300134e9870e3a3ec97b2eac4e114293bb0.tar.gz
gentoo-7750a300134e9870e3a3ec97b2eac4e114293bb0.tar.bz2
gentoo-7750a300134e9870e3a3ec97b2eac4e114293bb0.zip
dev-python/frozendict: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/files/frozendict-2.3.4-optional-extension.patch20
-rw-r--r--dev-python/frozendict/frozendict-2.3.4-r1.ebuild42
-rw-r--r--dev-python/frozendict/frozendict-2.3.4.ebuild31
4 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index c791a05a85f7..4bdae1f6bc76 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,2 +1 @@
-DIST frozendict-2.3.4.gh.tar.gz 307399 BLAKE2B ac6311182ed2ba4925a14a145b4d30a0241978f55ae7a81cebc534ede812ca77097f0f8c7eeb08e8cbd6240e036d3b5035bd3e9b284a55b638c93717e3a20258 SHA512 15acc4fceb5e2228ee3423d4a5b86c529e9bdcb7264f59139cbde6194983901a17da8036bebf53d7d8057ce52666031e90eb1ca358bfd374c651fd60743988dc
DIST frozendict-2.3.5.gh.tar.gz 307566 BLAKE2B 8d8b7d483e248be5de3c6e689dbb7e8dc40f8a8112456308e6a0e633dee04640aa0bb43edcf07e2a9829b87b8d082aa0926581622372224e9636cca27eaeaef0 SHA512 9e3820f2a24f2362f1be82049df871449a5225a927efa7735a2e9320e3c9f835a4a0a99a0037a3366df55a5744b38e96b358a9cc624defa79f45a5bff4c3b61d
diff --git a/dev-python/frozendict/files/frozendict-2.3.4-optional-extension.patch b/dev-python/frozendict/files/frozendict-2.3.4-optional-extension.patch
deleted file mode 100644
index f64402b023e3..000000000000
--- a/dev-python/frozendict/files/frozendict-2.3.4-optional-extension.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Autodetect availability of C extension. Taken from upstream PR.
-
-Upstream-PR: https://github.com/Marco-Sulla/python-frozendict/pull/69
-
-diff --git a/setup.py b/setup.py
-index 0325383..0667b59 100755
---- a/setup.py
-+++ b/setup.py
-@@ -163,7 +163,7 @@ if len(argv) > 1 and argv[1] in custom_args:
- impl = python_implementation()
-
- if custom_arg == None:
-- if impl == "PyPy":
-+ if impl == "PyPy" or not src_path.exists():
- custom_arg = "py"
- else:
- custom_arg = "c"
---
-2.39.1
-
diff --git a/dev-python/frozendict/frozendict-2.3.4-r1.ebuild b/dev-python/frozendict/frozendict-2.3.4-r1.ebuild
deleted file mode 100644
index 986217d9dcee..000000000000
--- a/dev-python/frozendict/frozendict-2.3.4-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple immutable mapping for python"
-HOMEPAGE="
- https://github.com/Marco-Sulla/python-frozendict/
- https://pypi.org/project/frozendict/
-"
-SRC_URI="
- https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/python-${P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${P}-optional-extension.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=()
- # skip tests of native extension for python versions where it is not available
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_IGNORE+=(
- test/test_frozendict_c.py
- test/test_frozendict_c_subclass.py
- )
-
- rm -rf frozendict || die
- epytest
-}
diff --git a/dev-python/frozendict/frozendict-2.3.4.ebuild b/dev-python/frozendict/frozendict-2.3.4.ebuild
deleted file mode 100644
index 9ba0f0bd0a42..000000000000
--- a/dev-python/frozendict/frozendict-2.3.4.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple immutable mapping for python"
-HOMEPAGE="
- https://github.com/Marco-Sulla/python-frozendict/
- https://pypi.org/project/frozendict/
-"
-SRC_URI="
- https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/python-${P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64"
-
-distutils_enable_tests pytest
-
-python_test() {
- cd "${T}" || die
- epytest "${S}/test"
-}