summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-10 07:34:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-10 07:34:38 +0200
commitfd76c58dc7b7eca7c138d2918dfb2208b3572232 (patch)
treefb34a81ae61f268777ac305ee7efa167f7850e2d /dev-python/frozendict
parentdev-python/pypdf: Bump to 3.7.1 (diff)
downloadgentoo-fd76c58dc7b7eca7c138d2918dfb2208b3572232.tar.gz
gentoo-fd76c58dc7b7eca7c138d2918dfb2208b3572232.tar.bz2
gentoo-fd76c58dc7b7eca7c138d2918dfb2208b3572232.zip
dev-python/frozendict: Bump to 2.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozendict')
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/frozendict-2.3.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index 291455434320..6649265a116a 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1,2 +1,3 @@
DIST frozendict-2.3.5.gh.tar.gz 307566 BLAKE2B 8d8b7d483e248be5de3c6e689dbb7e8dc40f8a8112456308e6a0e633dee04640aa0bb43edcf07e2a9829b87b8d082aa0926581622372224e9636cca27eaeaef0 SHA512 9e3820f2a24f2362f1be82049df871449a5225a927efa7735a2e9320e3c9f835a4a0a99a0037a3366df55a5744b38e96b358a9cc624defa79f45a5bff4c3b61d
DIST frozendict-2.3.6.gh.tar.gz 309471 BLAKE2B 1de3b0c2993243622d6f9c1058b086e3225216b6e80d0bc9b73b974ba2a1f18faa8ec97f5e1b3083e7ac4469517202fc273ec694f02e5405c5d4fc241acf9d14 SHA512 b57a77164f77b0f067e29377b7694ac9e4d7dbae617b649ed2018779dab5c3da27176481079386f43f3b3dc66a84cac0bd85b4b0b650072b812b3c6cffd06ba9
+DIST frozendict-2.3.7.gh.tar.gz 309663 BLAKE2B 108b27039ccf3c1ce9e002b7e459689a13a3f180c8f1da48373447bd19e2c937741df6a7173481a6a1f9441df5a30dd5c7f9394d83ae69e44022010bc199c0f3 SHA512 1f34e14a494c687be54ff8b40bc6c2fd329ddd4599fdfe940c96ef1df68e7b4bb88f3b6e1bbf7043ee403d091c4ab77062eb36e5fde4b4addc1762ed64f183b4
diff --git a/dev-python/frozendict/frozendict-2.3.7.ebuild b/dev-python/frozendict/frozendict-2.3.7.ebuild
new file mode 100644
index 000000000000..9548bcbf1869
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # This prevents the build system from ignoring build failures, sigh.
+ local -x CIBUILDWHEEL=1
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ rm -rf frozendict || die
+ epytest
+}