summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 16:40:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 16:42:02 +0200
commita88a9f5c9751315dc5bee43a39c917a05a0b70b3 (patch)
treea94f9d719d2d2ead6fed3b34d309133313b7c2de /dev-python/fs
parentdev-lang/python: Add a zipfile fix from upstream PR, as 3.12.0_p1 (diff)
downloadgentoo-a88a9f5c9751315dc5bee43a39c917a05a0b70b3.tar.gz
gentoo-a88a9f5c9751315dc5bee43a39c917a05a0b70b3.tar.bz2
gentoo-a88a9f5c9751315dc5bee43a39c917a05a0b70b3.zip
dev-python/fs: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.16.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/fs/fs-2.4.16.ebuild b/dev-python/fs/fs-2.4.16.ebuild
index 42594826f09b..2ff4052187be 100644
--- a/dev-python/fs/fs-2.4.16.ebuild
+++ b/dev-python/fs/fs-2.4.16.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1 optfeature pypi
DESCRIPTION="Filesystem abstraction layer"
@@ -23,6 +24,9 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-lang/python-3.12.0_p1
+ ' python3_12)
"
# NB: we skip tests requiring pyftpdlib
BDEPEND="