summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-20 07:54:54 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-20 07:55:07 +0200
commit1d93cac2e0feedc96321ba6221e7c92387a74b4c (patch)
treeab52bce83e83cb7057daacdc19bd128cee476e23 /dev-python/funcy/funcy-1.17.ebuild
parentnet-libs/grpc: drop 1.37.1-r2 (diff)
downloadgentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.tar.gz
gentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.tar.bz2
gentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.zip
dev-python/funcy: add 1.17
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/funcy/funcy-1.17.ebuild')
-rw-r--r--dev-python/funcy/funcy-1.17.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/funcy/funcy-1.17.ebuild b/dev-python/funcy/funcy-1.17.ebuild
new file mode 100644
index 000000000000..48dcf0ae3ec6
--- /dev/null
+++ b/dev-python/funcy/funcy-1.17.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/whatever[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests --install pytest