summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 09:04:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 11:46:19 +0100
commit05c280e37d14568d7a5a24eec6513aff907b94e8 (patch)
tree88231d8632913d1e50aa12f36564d80cced529a3 /dev-python/funcy
parentdev-python/botocore: Remove old (diff)
downloadgentoo-05c280e37d14568d7a5a24eec6513aff907b94e8.tar.gz
gentoo-05c280e37d14568d7a5a24eec6513aff907b94e8.tar.bz2
gentoo-05c280e37d14568d7a5a24eec6513aff907b94e8.zip
dev-python/funcy: Bump to 1.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/Manifest1
-rw-r--r--dev-python/funcy/funcy-1.18.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/funcy/Manifest b/dev-python/funcy/Manifest
index 47857b4044a7..f2ddf8c3358b 100644
--- a/dev-python/funcy/Manifest
+++ b/dev-python/funcy/Manifest
@@ -1 +1,2 @@
DIST funcy-1.17.tar.gz 112383 BLAKE2B 150133f72ed165bdc9adc3a9f4954dfd5b846dea7b1ee2cae0d6621ebaec3e2ba986cd6596fd86482036aad6476913caec0868db9cf55c067fdbf62ac10953e2 SHA512 d48ce3b7a7b8ee7512df109d651f40ca4dadf681acca6ab0a4857a2ea408f20f6345b9b416ca8b1e924050a842648192b8fe79381c202361bc4d2e25bd55ad05
+DIST funcy-1.18.tar.gz 277530 BLAKE2B 78e86e23b3908924de1de62dd567ff8ff52079a9a7529923c84f67a3c5f768d232164d758763db1ce941986c28012dbcb3c146412998b1d1d6064efcc0ff4bf9 SHA512 274fec59c1fddc58248b5f8c81686955706333bbd33a1d567f62694c70449ef2488fae6bf76418b8ff3c6655fad12ed344cc6c90a84c5b10412e32fbdda016fe
diff --git a/dev-python/funcy/funcy-1.18.ebuild b/dev-python/funcy/funcy-1.18.ebuild
new file mode 100644
index 000000000000..9a149505ee00
--- /dev/null
+++ b/dev-python/funcy/funcy-1.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="
+ https://github.com/Suor/funcy/
+ https://pypi.org/project/funcy/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest