summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-19 10:14:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-19 10:45:15 +0200
commit6502206f2d5560613958a648126c4c49263cde6d (patch)
treee488c84adddd1c7746045f95cfb2b55d7705413c /dev-python/git-review/git-review-9999.ebuild
parentdev-python/stripe: Bump to 2.73.0 (diff)
downloadgentoo-6502206f2d5560613958a648126c4c49263cde6d.tar.gz
gentoo-6502206f2d5560613958a648126c4c49263cde6d.tar.bz2
gentoo-6502206f2d5560613958a648126c4c49263cde6d.zip
dev-python/git-review: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/git-review/git-review-9999.ebuild')
-rw-r--r--dev-python/git-review/git-review-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/git-review/git-review-9999.ebuild b/dev-python/git-review/git-review-9999.ebuild
index bd9c8e269e6b..16e5454edee8 100644
--- a/dev-python/git-review/git-review-9999.ebuild
+++ b/dev-python/git-review/git-review-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-DISTUTILS_USE_SETUPTOOLS=
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -19,10 +20,13 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
-DEPEND=">=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/requests-1.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
python_prepare_all() {
sed -i -e '/manpages/,+1d' setup.cfg || die