summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-19 11:03:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-19 11:04:42 +0200
commit8d845ac6c6170cc83cf268dcc108b4c46ecaff7c (patch)
tree3876e32041618d62c47e72a4397575ff071eb068 /dev-python/gnome-python-base
parentnet-im/prosody: Add v0.11.5 and remove old 0.9 (diff)
downloadgentoo-8d845ac6c6170cc83cf268dcc108b4c46ecaff7c.tar.gz
gentoo-8d845ac6c6170cc83cf268dcc108b4c46ecaff7c.tar.bz2
gentoo-8d845ac6c6170cc83cf268dcc108b4c46ecaff7c.zip
dev-python/gnome-python-base: Revert "Remove last-rited pkg"
It was supposed to be gnome-python-desktop-base. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/Manifest1
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild45
-rw-r--r--dev-python/gnome-python-base/metadata.xml12
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/gnome-python-base/Manifest b/dev-python/gnome-python-base/Manifest
new file mode 100644
index 000000000000..31f334bab76f
--- /dev/null
+++ b/dev-python/gnome-python-base/Manifest
@@ -0,0 +1 @@
+DIST gnome-python-2.28.1.tar.bz2 562220 BLAKE2B 9bd14132974b6d42183debfc8f492fcee168a1671dfd27eead7aaa8d5ca12108bcda239b30df87bf41de3a0ab68191f095d63fdad05c151f6204f34f3bf14bdf SHA512 632d91d416f8209c2bc8d576d1229069e00f2cfeedb3441a5f151e12973ed740c0bb26d18d5c16cfeeb64ca35933537997277450001cffd96d8d5077027d45f2
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..dc93502945e4
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator eutils gnome2 python-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ python_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-allbindings
+}
diff --git a/dev-python/gnome-python-base/metadata.xml b/dev-python/gnome-python-base/metadata.xml
new file mode 100644
index 000000000000..e4e250dd8100
--- /dev/null
+++ b/dev-python/gnome-python-base/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>