summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:54:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:58:26 +0300
commit907374ef5d6ee574f4be4f6918a3fdcffa99c4ad (patch)
tree7df28b9ae9b156de430e6acb37bb4dc1ce2658a5 /dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild
parentdev-python/flask: add 2.2.2 (diff)
downloadgentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.tar.gz
gentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.tar.bz2
gentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.zip
dev-python/google-api-python-client: add 2.56.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild
new file mode 100644
index 000000000000..7e8aaa05d6d4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}