summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-03-29 00:55:19 -0400
committerMike Frysinger <vapier@gentoo.org>2018-03-29 00:58:00 -0400
commitd983457cbdc8161d73e4942448f6b09a458cc15b (patch)
tree358eb40ad64ca691f1b64d9cb90bd25461a9f499 /dev-python/google-apitools/files
parentdev-perl/XML-Stream: EAPI6 + tests (diff)
downloadgentoo-d983457cbdc8161d73e4942448f6b09a458cc15b.tar.gz
gentoo-d983457cbdc8161d73e4942448f6b09a458cc15b.tar.bz2
gentoo-d983457cbdc8161d73e4942448f6b09a458cc15b.zip
dev-python/google-apitools: drop cli/test/sample modules
Talking to upstream, the cli modules aren't generally useful, and gsutil (the only user of this currently) doesn't need it. By dropping that, we can drop the deprecated google-apputils project which doesn't support py3. We also clean up the install of unused sample & test modules. Now we can make it support python-3.
Diffstat (limited to 'dev-python/google-apitools/files')
-rw-r--r--dev-python/google-apitools/files/google-apitools-0.5.22-drop-cli.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/google-apitools/files/google-apitools-0.5.22-drop-cli.patch b/dev-python/google-apitools/files/google-apitools-0.5.22-drop-cli.patch
new file mode 100644
index 000000000000..cae369deefc3
--- /dev/null
+++ b/dev-python/google-apitools/files/google-apitools-0.5.22-drop-cli.patch
@@ -0,0 +1,21 @@
+we don't have code currently that uses the CLI tools, and the CLI tools require
+the apputils project, and that doesn't currently work with python3. drop it for
+now to get general python3 support.
+https://github.com/google/apitools/issues/8
+
+--- a/setup.py
++++ b/setup.py
+@@ -69,13 +69,7 @@ setuptools.setup(
+ author_email='craigcitro@google.com',
+ # Contained modules and scripts.
+ packages=setuptools.find_packages(),
+- entry_points={'console_scripts': CONSOLE_SCRIPTS},
+ install_requires=REQUIRED_PACKAGES,
+- tests_require=REQUIRED_PACKAGES + CLI_PACKAGES + TESTING_PACKAGES,
+- extras_require={
+- 'cli': CLI_PACKAGES,
+- 'testing': TESTING_PACKAGES,
+- },
+ # Add in any packaged data.
+ include_package_data=True,
+ package_data={