summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-09 21:06:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-09 21:19:10 +0200
commit136579d993603123491989e01801cc0038f082d8 (patch)
treed9ddeb4b922ff8255f8edb3c064f18c9f1887345 /dev-python/google-auth-oauthlib
parentdev-util/breakpad: fix HOMEPAGE (diff)
downloadgentoo-136579d993603123491989e01801cc0038f082d8.tar.gz
gentoo-136579d993603123491989e01801cc0038f082d8.tar.bz2
gentoo-136579d993603123491989e01801cc0038f082d8.zip
dev-python/google-auth-oauthlib: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 4e11beb1a618..ab1079bfb839 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1 +1,2 @@
DIST google-auth-library-python-oauthlib-0.5.1.gh.tar.gz 53101 BLAKE2B 2edaad7dbe42834d440bb30bcf836e01a575616160af045844da6c853f93a3a7a1c80367bbe58d47dbbdaf9e5b061abf780d9edd48f311e30d79025c934c3764 SHA512 628da0161739c9f0ba5963db6f21da71fde01ff81340d9242adcc74468c92c290693cfa4d98affed79556299621e74083992b54346c14940c1e88c5a5c683408
+DIST google-auth-library-python-oauthlib-0.5.2.gh.tar.gz 53842 BLAKE2B 7adcd9f339ec9a5528308fcc0fee1cbbe96440e1bfe5c7cc9c94808668e22801b612d291a2419333888194c3224838ac40f9d0656381825bd660067470f58910 SHA512 eaf296a0e0504e8249637a8db7531c10b120f28abeeab3e1fe8f366b4279c396509188e83f8a0ec56be85063430ceb691d6d926cee33d4f166bbcc4425e538db
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.2.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.2.ebuild
new file mode 100644
index 000000000000..9aa755ca297b
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest