summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-25 06:32:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-25 07:02:06 +0100
commit07eb814b9a2635293746babb1214023d68bcc58d (patch)
tree5fa28c89aeb564201832c58ec043fd3695a6d01f /dev-python/gsd
parentdev-python/Faker: Bump to 17.3.0 (diff)
downloadgentoo-07eb814b9a2635293746babb1214023d68bcc58d.tar.gz
gentoo-07eb814b9a2635293746babb1214023d68bcc58d.tar.bz2
gentoo-07eb814b9a2635293746babb1214023d68bcc58d.zip
dev-python/gsd: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 101cdb8785db..7463f5f7a149 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-v2.7.0.tar.gz 106584 BLAKE2B 9a37d04f2c975d84f8f2d23080cd934bcec3025e8a3047483a809527bc51424c5729966482bafe9c996c8e4c7c7f1594fc8292316f46dd676e6a88ad7b0360c2 SHA512 042c3ce97183068031a754e3e5676effd4d1e30406ac24e06510c72d2ceef22fdb8c62866cf7884aa578f18eadb1f7cb5385ebddfc8ede426a4fee6ecb7fb9fa
+DIST gsd-v2.8.0.tar.gz 107602 BLAKE2B 1317548dda93f7b7d07e74163f09aea9808ee50617e02c43f635339313e7604f5e06e0d488bdb7b336e96a7c80c1d1b1cbde0de6809102fedcfcdba2ced7c8ca SHA512 9346ed54a28d23cca9b1d3a82a86c4186dab47a6949e519e307ce121a3ed80105332360fb5a151cc68c403e00651746b2fef4d2c51781188a52569032f3bd700
diff --git a/dev-python/gsd/gsd-2.8.0.ebuild b/dev-python/gsd/gsd-2.8.0.ebuild
new file mode 100644
index 000000000000..6a8af0f7eea3
--- /dev/null
+++ b/dev-python/gsd/gsd-2.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.23.4[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}