summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-23 07:56:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-23 09:19:11 +0200
commitba72f1bc573cb2e52fa452ba399347e1fa1bedd7 (patch)
treecafb3bd8b7a17a0dda8557ec2f68930bbaa60b49 /dev-python/gsd
parentapp-admin/awscli: Bump to 1.25.15 (diff)
downloadgentoo-ba72f1bc573cb2e52fa452ba399347e1fa1bedd7.tar.gz
gentoo-ba72f1bc573cb2e52fa452ba399347e1fa1bedd7.tar.bz2
gentoo-ba72f1bc573cb2e52fa452ba399347e1fa1bedd7.zip
dev-python/gsd: Bump to 2.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.5.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 91cfffe0c474..58f2073ace29 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-v2.5.2.tar.gz 105448 BLAKE2B 408e66a91ea056e8c863e23dae439009e5f802f38d5e2a3b89bbb07c574ad61827fa9c2767729c37dcc8fa7ecb1fc3be922755da0ac0dc922ead2a365ce66a10 SHA512 2a2afb56b9f836608523b2946a0d2ca94511457506d02038d496b374ccb96dc0daad6435f9ee63b0937837b725d6288325c066d75d2ac0b0c6d9da4beb9eb082
+DIST gsd-v2.5.3.tar.gz 106104 BLAKE2B 39cadcca6a6660c736be8ce576b45d86a82a499bd21b6c818dcc6d307750940a8be85fdd63883d7aac9a416f5eddc55793ca2ab0da0b2373901c394d63ebe3f7 SHA512 3e3d5f8dece5553a4bc68b23aff8320b99169da5b995d1655da85c37e84a9e69d30f73ed3925e2e49b1c97dc875c594258dd15f3669337ca4c91914cab90d49c
diff --git a/dev-python/gsd/gsd-2.5.3.ebuild b/dev-python/gsd/gsd-2.5.3.ebuild
new file mode 100644
index 000000000000..30df9f182655
--- /dev/null
+++ b/dev-python/gsd/gsd-2.5.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}