summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-23 14:37:39 +0100
committerSam James <sam@gentoo.org>2023-05-30 19:05:06 +0100
commitaa008f367d4f852347ee4b5075693bda288ad4f6 (patch)
tree2b7a4acb46863ed93b12f39d3eb2b1e9546050fb /dev-python/gst-python/gst-python-1.22.3.ebuild
parentmedia-plugins/gst-plugins-faac: add 1.22.3 (diff)
downloadgentoo-aa008f367d4f852347ee4b5075693bda288ad4f6.tar.gz
gentoo-aa008f367d4f852347ee4b5075693bda288ad4f6.tar.bz2
gentoo-aa008f367d4f852347ee4b5075693bda288ad4f6.zip
dev-python/gst-python: add 1.22.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gst-python/gst-python-1.22.3.ebuild')
-rw-r--r--dev-python/gst-python/gst-python-1.22.3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/gst-python/gst-python-1.22.3.ebuild b/dev-python/gst-python/gst-python-1.22.3.ebuild
new file mode 100644
index 000000000000..c9cf1c309666
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.22.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}