summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:20:18 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:20:25 +0200
commit20eae0d9d43cd9a6e9156af9826c726e8f651458 (patch)
tree7504dad218267d10b6af68c3cebc90f271480950 /dev-python/helpdev
parentdev-python/flake8-polyfill: use pep517 (diff)
downloadgentoo-20eae0d9d43cd9a6e9156af9826c726e8f651458.tar.gz
gentoo-20eae0d9d43cd9a6e9156af9826c726e8f651458.tar.bz2
gentoo-20eae0d9d43cd9a6e9156af9826c726e8f651458.zip
dev-python/helpdev: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/helpdev')
-rw-r--r--dev-python/helpdev/helpdev-0.7.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/helpdev/helpdev-0.7.1-r1.ebuild b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..06bea21ab338
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest