summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/hiredis/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/hiredis/files')
-rw-r--r--dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch25
-rw-r--r--dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch28
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch b/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch
new file mode 100644
index 000000000000..298f5cf7ee2e
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch
@@ -0,0 +1,25 @@
+--- hiredis-0.1.1/setup.py
++++ hiredis-0.1.1/setup.py
+@@ -20,13 +20,9 @@
+ if self.distribution.has_ext_modules():
+ self.run_command('build_ext')
+
+-lib = ("hiredis", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("hiredis", "net", "sds")],
+- "include_dirs": ["vendor/hiredis"]})
+-
+ ext = Extension("hiredis.hiredis",
+ sources=glob.glob("src/*.c"),
+- include_dirs=["src", "vendor"],
++ include_dirs=["src"],
+ libraries=["hiredis"])
+
+ setup(
+@@ -39,7 +35,6 @@
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command
diff --git a/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
new file mode 100644
index 000000000000..6cd22292deb9
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
@@ -0,0 +1,28 @@
+Remove vendor and var 'lib' from setup.py
+diff -u hiredis-0.2.0.orig/setup.py hiredis-0.2.0/setup.py
+--- setup.py 2015-06-21 11:47:28.796472027 +0800
++++ setup.py 2015-06-21 11:49:53.047949803 +0800
+@@ -40,12 +40,9 @@
+ # supported Python versions is worse...
+ #
+ # Also see: https://github.com/pietern/hiredis-py/issues/15
+-lib = ("hiredis_for_hiredis_py", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("read", "sds")]})
+
+ ext = Extension("hiredis.hiredis",
+- sources=glob.glob("src/*.c"),
+- include_dirs=["vendor"])
++ sources=glob.glob("src/*.c"))
+
+ setup(
+ name="hiredis",
+@@ -57,7 +54,6 @@
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command
+Common subdirectories: hiredis-0.2.0.orig/src and hiredis-0.2.0/src
+Common subdirectories: hiredis-0.2.0.orig/vendor and hiredis-0.2.0/vendor