summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-05 17:26:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-05 18:07:00 +0100
commitba53b27075b89e5a06888f1e0628cb0d847f9f83 (patch)
tree16b396c27f6a11a920926171f66c873d1dd9b31a /dev-python/humanize/humanize-4.6.0.ebuild
parentdev-python/websocket-client: Bump to 1.5.1 (diff)
downloadgentoo-ba53b27075b89e5a06888f1e0628cb0d847f9f83.tar.gz
gentoo-ba53b27075b89e5a06888f1e0628cb0d847f9f83.tar.bz2
gentoo-ba53b27075b89e5a06888f1e0628cb0d847f9f83.zip
dev-python/humanize: Bump to 4.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize/humanize-4.6.0.ebuild')
-rw-r--r--dev-python/humanize/humanize-4.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/humanize/humanize-4.6.0.ebuild b/dev-python/humanize/humanize-4.6.0.ebuild
new file mode 100644
index 000000000000..a6a67e24c908
--- /dev/null
+++ b/dev-python/humanize/humanize-4.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest