summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:26:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:11 +0100
commit17b6a24486d0cca2fe20f28562680a3477642c14 (patch)
tree296c68ed4ca2a24a82fa54246b36486f92a0f473 /dev-python/icalendar/icalendar-5.0.4.ebuild
parentapp-admin/awscli: Bump to 1.27.40 (diff)
downloadgentoo-17b6a24486d0cca2fe20f28562680a3477642c14.tar.gz
gentoo-17b6a24486d0cca2fe20f28562680a3477642c14.tar.bz2
gentoo-17b6a24486d0cca2fe20f28562680a3477642c14.zip
dev-python/icalendar: Bump to 5.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar/icalendar-5.0.4.ebuild')
-rw-r--r--dev-python/icalendar/icalendar-5.0.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/icalendar/icalendar-5.0.4.ebuild b/dev-python/icalendar/icalendar-5.0.4.ebuild
new file mode 100644
index 000000000000..c68083d1dacb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}