summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-27 21:39:57 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-27 21:48:30 +0200
commit33d97dc7e7fedd37fe542d4c6726814d0e4bf1f2 (patch)
tree4a12eb810b3652fc0b4176c7fc63af334c0c6d37 /dev-python/identify/identify-2.4.6.ebuild
parentmedia-libs/libwebp: bump to 1.2.2 (diff)
downloadgentoo-33d97dc7e7fedd37fe542d4c6726814d0e4bf1f2.tar.gz
gentoo-33d97dc7e7fedd37fe542d4c6726814d0e4bf1f2.tar.bz2
gentoo-33d97dc7e7fedd37fe542d4c6726814d0e4bf1f2.zip
dev-python/identify: add 2.4.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/identify/identify-2.4.6.ebuild')
-rw-r--r--dev-python/identify/identify-2.4.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.4.6.ebuild b/dev-python/identify/identify-2.4.6.ebuild
new file mode 100644
index 000000000000..4a00d7b29ab7
--- /dev/null
+++ b/dev-python/identify/identify-2.4.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-python/ukkonen[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest