summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-28 07:57:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-28 09:08:49 +0200
commitec974468f607e8c6052549581568e42f5d9438d6 (patch)
tree339cd6ac01ca64f7730a7119ca9cbdd780228e13 /dev-python/identify
parentdev-python/autopep8: Bump to 1.7.1 (diff)
downloadgentoo-ec974468f607e8c6052549581568e42f5d9438d6.tar.gz
gentoo-ec974468f607e8c6052549581568e42f5d9438d6.tar.bz2
gentoo-ec974468f607e8c6052549581568e42f5d9438d6.zip
dev-python/identify: Bump to 2.5.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.8.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 79ae20eadd8c..0c08708b032e 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,4 @@
DIST identify-2.5.5.gh.tar.gz 101461 BLAKE2B b3a4dc2273435cf9244af64b08b9a9a922025f7d32f479fb2641fcdd9f8a05d2778db126104b1e3b765b82af7ecc1660163de1f71098900296135cd1ccd129c5 SHA512 e02688805310a4f92d0435af562383a10297afa7fc468e44f73be40118c73e2ceac1b4ba7525c375fd0b671ea2700ba66307115c78558a370c525de8cba33c83
DIST identify-2.5.6.gh.tar.gz 101460 BLAKE2B c540934d4a482521758a64a1eb5e84b346eef0e0cccecbb9ad06e53e4b6872acb9c6fc94fccab9b75a7cf5658af78ad319d808a17f7ec44dfd08ae9c9a3b9f58 SHA512 9a35eb42767b0d2365b8da7c5aa5d7644272de5b65a505c5876cce0781222d8e52937b5c2d5594e560c5ab2fbbf4329555df15443b8f6110ac48880691af9089
DIST identify-2.5.7.gh.tar.gz 101472 BLAKE2B 519f35e08258dac5ff4b897f4ee55cf432641e57c55ff1d05d3fdf564aa7eed441ba839f222b430eae96f55a8e6a5d14a9c25fc78b3536dad59c3604a3bff7c2 SHA512 186a0c36e3abadd4b2db1439daa837fed55db706c4eb1821d9ecf1288cd667706b708e1251f84d67a480cdd28e6a57960443b707c327e19a9342f5e2afdb1a7c
+DIST identify-2.5.8.gh.tar.gz 101476 BLAKE2B 2b59ac3cb416c7e3d6bd4031bfed30594b9be70f94d1e0d8e9f436b76e9241cde32f847c0f6b40607d2cb37ff7d67270a35a4d22be4cd6b216324e4eba30f136 SHA512 b43b8ba50d4d58a6d82c99141c708a45317f64693aea567105ed7f3957446e00102ddd303120a9f1238b04b6e0655e1dd6f807f6d878e972c7967a510f8b24b2
diff --git a/dev-python/identify/identify-2.5.8.ebuild b/dev-python/identify/identify-2.5.8.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest