summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-22 10:41:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 15:03:04 +0200
commit3e8499dcda7470317b6e71af27fb7319c5f9af00 (patch)
tree6079b8952c7fb551816512d3de844498aa5a82ac /dev-python/ijson
parentdev-python/ijson: Revert "add 3.2.3" (diff)
downloadgentoo-3e8499dcda7470317b6e71af27fb7319c5f9af00.tar.gz
gentoo-3e8499dcda7470317b6e71af27fb7319c5f9af00.tar.bz2
gentoo-3e8499dcda7470317b6e71af27fb7319c5f9af00.zip
dev-python/ijson: Bump to 3.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.2.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index a048e298bb40..0af3fab50553 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-3.2.2.gh.tar.gz 127965 BLAKE2B 2e20f7cc822406fe3e7eec99c3ef394e42d90b0b518226a7b8eb078763cb8317acb4a28934301116c32a2a9cc37403c2950b18232800485b1ea1206dace7ff23 SHA512 5935071bd0d3eecc39b3c30ca5cb2a959e4d455c57e36414d5c97ba71bbcf1a0b53c8b8afed7551a3a4ac4595294105566c9d7501b35832dd7e46a1bb2151287
+DIST ijson-3.2.3.tar.gz 57596 BLAKE2B e85465829f8319e2e227b7b72633b65e7e77a8cd24fee877aded1f50383ffbbaddd82e5e3942c0b3f637a8e601c5101aa390889e8509ee2c61b6f3c9cf9a7249 SHA512 ca72ed08c7804611d7f9c5218d217087fe17358859d080741726b42072df1407afcf1f701e30d33f3f615e8c78ba247a3cc45e8e7e373f1d3168a63f397fd6eb
diff --git a/dev-python/ijson/ijson-3.2.3.ebuild b/dev-python/ijson/ijson-3.2.3.ebuild
new file mode 100644
index 000000000000..1cacc738a0c5
--- /dev/null
+++ b/dev-python/ijson/ijson-3.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson/
+ https://pypi.org/project/ijson/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/yajl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+export IJSON_BUILD_YAJL2C=1
+
+python_test() {
+ rm -rf ijson || die
+ epytest
+}