summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-24 20:40:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-24 20:40:13 +0200
commit4e616cc929bc63ec96bf622d312d8d407476a29d (patch)
tree39191cddd7a4b6f20478742aece5e2e5119a2d92 /dev-python/imapclient
parentdev-python/importlib_resources: Remove old (diff)
downloadgentoo-4e616cc929bc63ec96bf622d312d8d407476a29d.tar.gz
gentoo-4e616cc929bc63ec96bf622d312d8d407476a29d.tar.bz2
gentoo-4e616cc929bc63ec96bf622d312d8d407476a29d.zip
dev-python/imapclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imapclient')
-rw-r--r--dev-python/imapclient/Manifest2
-rw-r--r--dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch13
-rw-r--r--dev-python/imapclient/imapclient-2.2.0-r1.ebuild31
-rw-r--r--dev-python/imapclient/imapclient-2.2.0.ebuild27
4 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/imapclient/Manifest b/dev-python/imapclient/Manifest
index 67bd5e0feda5..1fb691c27a24 100644
--- a/dev-python/imapclient/Manifest
+++ b/dev-python/imapclient/Manifest
@@ -1,3 +1 @@
-DIST imapclient-2.2.0.gh.tar.gz 89505 BLAKE2B 448e8c736cd80f261c50dd7d6fe88498bf988e475f8135bf7079021d0154904741ab8af28c0ede817ec1bd8c7bd329b1c891c24e37c3466d68287afa02d636c7 SHA512 ace8f55e0f7f4dbb9127b2bbf26cce4c12dce40357cf8127aa6e377321d5156f91f913bd4d4ca57bd5b7f0c86ae5d0b7fdf352b74a6edb7d607f46aa45a144a2
-DIST imapclient-2.2.0.tar.gz 89505 BLAKE2B 448e8c736cd80f261c50dd7d6fe88498bf988e475f8135bf7079021d0154904741ab8af28c0ede817ec1bd8c7bd329b1c891c24e37c3466d68287afa02d636c7 SHA512 ace8f55e0f7f4dbb9127b2bbf26cce4c12dce40357cf8127aa6e377321d5156f91f913bd4d4ca57bd5b7f0c86ae5d0b7fdf352b74a6edb7d607f46aa45a144a2
DIST imapclient-2.3.1.gh.tar.gz 91141 BLAKE2B c4efbdb4a513277039389e13d0f86498df3bb4c466026510fba55a8cf88316a3c5b02c15215e3e40e8e0b6206e8bd4659e75b1f83ba2a905a2aaec21f8af4b48 SHA512 06a9264e8cc001b8a4a6a855032bbb9b904c94999d090c3f1bedea1ae3a16524f668eb4dfa36e7a23a0622bd9d3e83191dcc1e5e30275cb6fcb7604142e5e2a6
diff --git a/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch b/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch
deleted file mode 100644
index b3a12823f6a5..000000000000
--- a/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/mjs/imapclient/issues/466
-https://bugs.gentoo.org/835498
---- a/imapclient/tls.py
-+++ b/imapclient/tls.py
-@@ -27,7 +27,7 @@ def wrap_socket(sock, ssl_context, host):
- return ssl.wrap_socket(sock)
-
- if ssl_context is None:
-- ssl_context = ssl.create_default_context()
-+ ssl_context = ssl.create_default_context(purpose=ssl.Purpose.SERVER_AUTH)
-
- return ssl_context.wrap_socket(sock, server_hostname=host)
-
diff --git a/dev-python/imapclient/imapclient-2.2.0-r1.ebuild b/dev-python/imapclient/imapclient-2.2.0-r1.ebuild
deleted file mode 100644
index 520ba497b462..000000000000
--- a/dev-python/imapclient/imapclient-2.2.0-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
-HOMEPAGE="https://github.com/mjs/imapclient"
-SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.0-ssl-context.patch
-)
-
-distutils_enable_sphinx doc/src
-distutils_enable_tests unittest
-
-python_install_all() {
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}
diff --git a/dev-python/imapclient/imapclient-2.2.0.ebuild b/dev-python/imapclient/imapclient-2.2.0.ebuild
deleted file mode 100644
index 0c541676f444..000000000000
--- a/dev-python/imapclient/imapclient-2.2.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
-HOMEPAGE="https://github.com/mjs/imapclient"
-SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx doc/src
-distutils_enable_tests unittest
-
-python_install_all() {
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}