summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-03 09:16:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-03 10:31:57 +0300
commitf83fdd8a7564d0d68c9eae878ab073c73d861e86 (patch)
treeb730a1cedf56a64b5612b2f6f3ab8502024c85ce /dev-python/imread
parentdev-python/pypy-exe-bin: Remove old (diff)
downloadgentoo-f83fdd8a7564d0d68c9eae878ab073c73d861e86.tar.gz
gentoo-f83fdd8a7564d0d68c9eae878ab073c73d861e86.tar.bz2
gentoo-f83fdd8a7564d0d68c9eae878ab073c73d861e86.zip
dev-python/imread: enable py3.10, EAPI=8, fix docs gen
Closes: https://bugs.gentoo.org/801559 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/imread')
-rw-r--r--dev-python/imread/imread-0.7.3-r1.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-python/imread/imread-0.7.3-r1.ebuild b/dev-python/imread/imread-0.7.3-r1.ebuild
index 67926fc8db61..bc7b8753a584 100644
--- a/dev-python/imread/imread-0.7.3-r1.ebuild
+++ b/dev-python/imread/imread-0.7.3-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Read Image Files"
@@ -20,14 +19,10 @@ RDEPEND="
media-libs/libpng:0
media-libs/libwebp:0
media-libs/tiff:0
- "
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ virtual/jpeg
"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-distutils_enable_sphinx docs \
- 'dev-python/numpydoc'
-
+distutils_enable_sphinx docs/source
distutils_enable_tests setup.py