summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-08-24 15:18:21 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-08-24 15:18:21 +0200
commit5e100f0b4892c506537f03f7dbc805433c18dca9 (patch)
treef0ac688fdd9a170bd5782bef136146902f38ee19 /dev-python/inflection/inflection-0.5.1.ebuild
parentdev-python/dominate: bump to 2.5.2, add Python 3.9 support (diff)
downloadgentoo-5e100f0b4892c506537f03f7dbc805433c18dca9.tar.gz
gentoo-5e100f0b4892c506537f03f7dbc805433c18dca9.tar.bz2
gentoo-5e100f0b4892c506537f03f7dbc805433c18dca9.zip
dev-python/inflection: bump to 0.5.1
Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/inflection/inflection-0.5.1.ebuild')
-rw-r--r--dev-python/inflection/inflection-0.5.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/inflection/inflection-0.5.1.ebuild b/dev-python/inflection/inflection-0.5.1.ebuild
new file mode 100644
index 000000000000..2198c8bc6729
--- /dev/null
+++ b/dev-python/inflection/inflection-0.5.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A port of Ruby on Rails' inflector to Python"
+HOMEPAGE="https://github.com/jpvanhal/inflection"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest