summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-06 14:07:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-06 14:22:30 +0100
commitcbf0ba8d926be7101a8d7cbf19cd2061dbc8584c (patch)
treead24ca16de986a270d783c29adf9ec7e5b88f9d7 /dev-python/isort/isort-5.12.0.ebuild
parentdev-python/isort: Remove test dep on dev-python/pylama (diff)
downloadgentoo-cbf0ba8d926be7101a8d7cbf19cd2061dbc8584c.tar.gz
gentoo-cbf0ba8d926be7101a8d7cbf19cd2061dbc8584c.tar.bz2
gentoo-cbf0ba8d926be7101a8d7cbf19cd2061dbc8584c.zip
dev-python/isort: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort/isort-5.12.0.ebuild')
-rw-r--r--dev-python/isort/isort-5.12.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/isort/isort-5.12.0.ebuild b/dev-python/isort/isort-5.12.0.ebuild
index 6a9a23af7de4..e3f28e100a52 100644
--- a/dev-python/isort/isort-5.12.0.ebuild
+++ b/dev-python/isort/isort-5.12.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -39,6 +39,11 @@ BDEPEND="
distutils_enable_tests pytest
src_prepare() {
+ local PATCHES=(
+ # https://github.com/PyCQA/isort/pull/2196
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
# unbundle tomli
sed -i -e 's:from ._vendored ::' isort/settings.py || die
rm -r isort/_vendored || die