summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-06-26 15:11:17 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-27 08:46:55 -0400
commita6bda1d212f9022e111979d5ebe41bd944629ef3 (patch)
treee21973b4e91d5a9b44f88d92abc35b08485a9b48 /dev-python/jaraco-classes/jaraco-classes-1.4.ebuild
parentdev-util/eric: Migrate from LINGUAS to L10N. (diff)
downloadgentoo-a6bda1d212f9022e111979d5ebe41bd944629ef3.tar.gz
gentoo-a6bda1d212f9022e111979d5ebe41bd944629ef3.tar.bz2
gentoo-a6bda1d212f9022e111979d5ebe41bd944629ef3.zip
dev-python/jaraco-classes: bump to 1.4
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/jaraco-classes/jaraco-classes-1.4.ebuild')
-rw-r--r--dev-python/jaraco-classes/jaraco-classes-1.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jaraco-classes/jaraco-classes-1.4.ebuild b/dev-python/jaraco-classes/jaraco-classes-1.4.ebuild
new file mode 100644
index 000000000000..cca259465f2a
--- /dev/null
+++ b/dev-python/jaraco-classes/jaraco-classes-1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Classes used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.classes"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}