summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 07:18:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-30 07:39:04 +0100
commit23bcb3df65edacae59afdf817313da4b2c053073 (patch)
tree7c1110fda2eef19f7d0e3986bb75e1ad2f1e20f5 /dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild
parentdev-python/httplib2: Bump to 0.21.0 (diff)
downloadgentoo-23bcb3df65edacae59afdf817313da4b2c053073.tar.gz
gentoo-23bcb3df65edacae59afdf817313da4b2c053073.tar.bz2
gentoo-23bcb3df65edacae59afdf817313da4b2c053073.zip
dev-python/jaraco-collections: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild
new file mode 100644
index 000000000000..93d208be4d8a
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest