summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-31 07:12:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-31 07:12:15 +0200
commit9f4749377d66bc3ce0c12e07177b21a9a586bcdd (patch)
tree3ec2870fba56a735f20fdec5fe951d7b7f940913 /dev-python/jedi
parentdev-python/pandas: Link upstream build system bugs (diff)
downloadgentoo-9f4749377d66bc3ce0c12e07177b21a9a586bcdd.tar.gz
gentoo-9f4749377d66bc3ce0c12e07177b21a9a586bcdd.tar.bz2
gentoo-9f4749377d66bc3ce0c12e07177b21a9a586bcdd.zip
dev-python/jedi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.18.2.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index ac66f432e872..39b084235fce 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,4 +1,3 @@
DIST django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9.tar.gz 183312 BLAKE2B a68f6139903f5001db994ee0d881f40ab74932e81c3e2c3a0c22dc56e6be681d0fb42ce837603b21e4d0d448ccb25884ef0f69039305f309e82603267cee9f6a SHA512 506322c132f94e6a1e88cdbde6027a566387731fa6ad59934f95c3511f49d90eff2a3138363811be648b096407d418cd1f801df0bc35b1e464ef181e4076ada1
-DIST jedi-0.18.2.gh.tar.gz 469286 BLAKE2B 6b65a231d092a6869b55c14a8254c4716695f46cdc9733f50607cf7bb8c864f319e2abfbe812bffc514c78cd92059fc29fa9cc0a38b1e14d6bc8bf3ad3596097 SHA512 1df24190c7d468f388e7175f4625670df81cd9a533c8bde12b1e0eaf982a173bdd001bbea6680144cc50ca263fa2b802da5d71de555f81717f4377c46826d0d1
DIST jedi-0.19.0.gh.tar.gz 472334 BLAKE2B 04e8fda32c2d0b0476d197c5686011f811d5c269cdb61b15d0bafa9e3aabed05deb44f98d2e3a25faf7bd130b3a9289d058ed06199fc760357d34c551ecc5ad0 SHA512 0db8c7859e55057afc0367455c2f3817d8f05a19b6fbdc163a74f07854562c9c29307c7f8ac92e0ce9349353ac148f728a25b3be4cc62dc35f3060bdb79b02c8
DIST typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3.tar.gz 602044 BLAKE2B 53298918a7e9a1163e76d4c70ad2a2117ee90b49329aa82d82b2aaaeaf000c971872f83ed283af6dc4be068b813876760c8b1b4acb4131865572a4aed3ea9230 SHA512 b3b9da66b6c6e03e0b262b3262df31215a5e080468ca9ebf4332ed53d715cd3956db7067fad3ec267042ff704f81ac665c703ef2fd0c5b445d440bd8e52bf1aa
diff --git a/dev-python/jedi/jedi-0.18.2.ebuild b/dev-python/jedi/jedi-0.18.2.ebuild
deleted file mode 100644
index a657d902aae0..000000000000
--- a/dev-python/jedi/jedi-0.18.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-TYPESHED_P="typeshed-ae9d4f4b21bb5e1239816c301da7b1ea904b44c3"
-DJANGO_STUBS_P="django-stubs-fd057010f6cbf176f57d1099e82be46d39b99cb9"
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="
- https://github.com/davidhalter/jedi/
- https://pypi.org/project/jedi/
-"
-SRC_URI="
- https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz
- -> ${TYPESHED_P}.tar.gz
- https://github.com/davidhalter/django-stubs/archive/${DJANGO_STUBS_P#django-stubs-}.tar.gz
- -> ${DJANGO_STUBS_P/v/}.tar.gz
-"
-
-LICENSE="
- MIT
- test? ( Apache-2.0 )
-"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- =dev-python/parso-0.8*[${PYTHON_USEDEP}]
-"
-
-# RDEPEND needed because of an import jedi inside conf.py
-distutils_enable_sphinx docs \
- dev-python/parso \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # upstream includes these as submodules ...
- rmdir "${S}"/jedi/third_party/{django-stubs,typeshed} || die
- mv "${WORKDIR}/${DJANGO_STUBS_P/v/}" \
- "${S}/jedi/third_party/django-stubs" || die
- mv "${WORKDIR}/${TYPESHED_P}" \
- "${S}/jedi/third_party/typeshed" || die
-
- # don't run doctests, don't depend on colorama
- sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
- sed -i "s: --doctest-modules::" pytest.ini || die
-
- # test_complete_expanduser relies on $HOME not being empty
- > "${HOME}"/somefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fragile
- test/test_speed.py
- # assumes pristine virtualenv
- test/test_inference/test_imports.py::test_os_issues
- )
- [[ ${EPYTHON} != python3.8 ]] && EPYTEST_DESELECT+=(
- # TODO
- 'test/test_integration.py::test_completion[lambdas:112]'
- )
-
- # some plugin breaks case-insensitivity on completions
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # django and pytest tests are very version dependent
- epytest -k "not django and not pytest"
-}