summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-26 12:43:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-26 12:45:36 +0200
commitb9b6f16246b21c0d4dbd5bc21b2ee4991c24fba4 (patch)
tree2068360f207cc607944a9c84fbe007df4169c4e0 /dev-python/joblib
parentdev-python/loky: enable py3.11 (diff)
downloadgentoo-b9b6f16246b21c0d4dbd5bc21b2ee4991c24fba4.tar.gz
gentoo-b9b6f16246b21c0d4dbd5bc21b2ee4991c24fba4.tar.bz2
gentoo-b9b6f16246b21c0d4dbd5bc21b2ee4991c24fba4.zip
dev-python/joblib: pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/joblib-1.1.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/joblib/joblib-1.1.0-r1.ebuild b/dev-python/joblib/joblib-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f627bd235c06
--- /dev/null
+++ b/dev-python/joblib/joblib-1.1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ # https://github.com/joblib/joblib/issues/1115
+ sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
+ -i joblib/test/test_memory.py || die
+
+ distutils-r1_python_prepare_all
+}