summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-03 19:17:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-03 19:21:12 -0500
commit0f4963a9cb4fb24a310c5a0bbfc6f7c44a768d9b (patch)
tree6d2b5eb880121df2f1b23110fd48c685678bd2df /dev-python/josepy/josepy-1.1.0.ebuild
parentsys-apps/portage: version bump to 2.3.35 (diff)
downloadgentoo-0f4963a9cb4fb24a310c5a0bbfc6f7c44a768d9b.tar.gz
gentoo-0f4963a9cb4fb24a310c5a0bbfc6f7c44a768d9b.tar.bz2
gentoo-0f4963a9cb4fb24a310c5a0bbfc6f7c44a768d9b.zip
dev-python/josepy: 1.1.0 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-python/josepy/josepy-1.1.0.ebuild')
-rw-r--r--dev-python/josepy/josepy-1.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/josepy/josepy-1.1.0.ebuild b/dev-python/josepy/josepy-1.1.0.ebuild
new file mode 100644
index 000000000000..11712885f363
--- /dev/null
+++ b/dev-python/josepy/josepy-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="JOSE protocol implementation in Python"
+HOMEPAGE="https://github.com/jezdez/josepy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<=app-crypt/acme-0.20.0"