summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 10:08:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 10:56:56 +0200
commitb4d693e926bc6b9c837908ba7d260fa27601bcb1 (patch)
treeb217cc62a442293ad5ae297cc75e20e16b7a4489 /dev-python/json5/json5-0.9.8.ebuild
parentdev-python/imageio: Bump to 2.19.1 (diff)
downloadgentoo-b4d693e926bc6b9c837908ba7d260fa27601bcb1.tar.gz
gentoo-b4d693e926bc6b9c837908ba7d260fa27601bcb1.tar.bz2
gentoo-b4d693e926bc6b9c837908ba7d260fa27601bcb1.zip
dev-python/json5: Bump to 0.9.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/json5/json5-0.9.8.ebuild')
-rw-r--r--dev-python/json5/json5-0.9.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/json5/json5-0.9.8.ebuild b/dev-python/json5/json5-0.9.8.ebuild
new file mode 100644
index 000000000000..f32c70f5016e
--- /dev/null
+++ b/dev-python/json5/json5-0.9.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest