summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-17 14:08:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-17 14:33:48 +0100
commit004fd8edc58ff455876f86bbe3a17dc19e413a9b (patch)
tree1a259a108d23370d5c576fddef4f79b5912b69a0 /dev-python/jsonschema-spec
parentdev-python/zope-interface: Bump to 6.0 (diff)
downloadgentoo-004fd8edc58ff455876f86bbe3a17dc19e413a9b.tar.gz
gentoo-004fd8edc58ff455876f86bbe3a17dc19e413a9b.tar.bz2
gentoo-004fd8edc58ff455876f86bbe3a17dc19e413a9b.zip
dev-python/jsonschema-spec: Bump to 0.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest1
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index 1ec13dd084b7..1fe164fa9f39 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1 +1,2 @@
DIST jsonschema-spec-0.1.3.gh.tar.gz 30794 BLAKE2B 545eda0aef433eb62cd02bbcc4d07469b26c477bbf572d71bcb4eb126acc5ab912f5f80c0699305b37f7f526f36910bcb019d66a763e679846bb20a5b01eb813 SHA512 95465c43b842289ed28dd78ec06614d77b2bbf7d9d69e5dc4b89008740d0cc85e5b3319acd66d0142b533425e8f150c4edbbf15b7f8e3bdefb28b81193a13432
+DIST jsonschema-spec-0.1.4.gh.tar.gz 30903 BLAKE2B eae7ba8b811dfd14d9b2e33d3355bf8c98e088b1a8fa3314300dcc7edae31727cc5a01d0a06af412b8c7d59eca69ba816f6eb2683e997719fd300a3445e96cfd SHA512 6b3d1710fdd8c43a0f38d0687c95e4e70c55df964dc597e4a00abad3459610829bd90190b21c512c70d46498d98b80ecc2422eb73d7822539841ff10bc7c2c4f
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild
new file mode 100644
index 000000000000..66fd3efcb98b
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}