summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-17 08:34:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-17 08:57:11 +0100
commit87e7f698cc3d8c5e710a2dba8a1c0ec3312a4a74 (patch)
tree582e4d4ab2abc5171fc17cc76514e6f0d6b656a9 /dev-python/jsonschema
parentdev-python/rpds-py: Bump to 0.13.0 (diff)
downloadgentoo-87e7f698cc3d8c5e710a2dba8a1c0ec3312a4a74.tar.gz
gentoo-87e7f698cc3d8c5e710a2dba8a1c0ec3312a4a74.tar.bz2
gentoo-87e7f698cc3d8c5e710a2dba8a1c0ec3312a4a74.zip
dev-python/jsonschema: Bump to 4.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.20.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 2d779d1f6d60..3a8a1ad440c8 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,4 @@
DIST jsonschema-4.17.3.tar.gz 297785 BLAKE2B a0383bf5612ae50e94c95dbc1774d796b62c74a7aae3056a40edb7e042ad07fd7885e61d86220120a906a4017afe30d8ee8edbbf0cf01a6dec1f212984ff1c1e SHA512 626fc913c37d2e49e4b47c9e058aab4a96c1dc50c35d8def0b2ea0ca464dc25e3318d4fde4927c11ca38068743cd81779d5189464b821407ac1de1788bad30e2
DIST jsonschema-4.19.1.tar.gz 318089 BLAKE2B 63ddd573ec47bc1c58c2b1bc4a20dd833c4c041de69b8c2e3cfa24c3494d3879fb09914491758ef38e8ae775b347f68d1d9c2e4d3cfc087dbd8c55d381cccd66 SHA512 60fa769faf6e3fc2c14eb9acd189c86e9d366b157230a5681d36552af0c159cb1ad33fd920668a36afdab98bc97253f91501704c5c07b5009fdaf9d29b52060d
DIST jsonschema-4.19.2.tar.gz 318786 BLAKE2B 2906344281ffa50ac1256c37025aa74ac8267af25187d3e13e6f1be219027e16a8fb4a6cdf778e6d0be4adf727d4393281fd8e5ffceef608fb40cb322361e20c SHA512 0820f0e6417cceb1017efe9b8fed6e386acbb194e786c97c89a94f173c22a8dfa8144f19ae46cbf44cb3d2b78b27d4631344e13e964d82d9810a513d328a95a0
+DIST jsonschema-4.20.0.tar.gz 320243 BLAKE2B 7782665aa97d080a3ade9f0ed600d84602135ba80641c75d027f31f118432d206d5c61243e90a59aa134bce2fcf6bed6aed685bca9ad243178c78d3002d43b66 SHA512 916ce6e5a1cce19e52d34394797d59c4821a3e7abad0248d929a8d5975e8e5a2c0a270b2839d6e1800037a53d0ed8fd38ca44264a88653b5aaba1705d459cb47
diff --git a/dev-python/jsonschema/jsonschema-4.20.0.ebuild b/dev-python/jsonschema/jsonschema-4.20.0.ebuild
new file mode 100644
index 000000000000..b12e660f41a2
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.20.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ !!dev-python/shiboken6
+ )
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri-template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)