summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-05 09:38:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-05 09:38:25 +0200
commit4d95bbe04356d7814faa2e1f91a471b3615bf47f (patch)
tree86a098e4bc4179972deaeb04bc2e8eefd5a5e357 /dev-python/jupyter-client
parentdev-python/pytest-httpbin: Remove old (diff)
downloadgentoo-4d95bbe04356d7814faa2e1f91a471b3615bf47f.tar.gz
gentoo-4d95bbe04356d7814faa2e1f91a471b3615bf47f.tar.bz2
gentoo-4d95bbe04356d7814faa2e1f91a471b3615bf47f.zip
dev-python/jupyter-client: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest1
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.6.2.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 2869a7c4ba66..6a2d0b855cd8 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,2 +1 @@
-DIST jupyter_client-8.6.2.tar.gz 341102 BLAKE2B d9d04b6b965aa34f6b1dd228d1389a36509415e57cb66b4aede37963b6a48f5133c48e8343bbb54bd775b3faa59db8b248f515caca9dbbe594a9d4ba93a668d7 SHA512 ce0ae60b083ce0a37ddd0249d3caef0581ece61927ae685ee80b55d9431557352f1dce6cf81894d39343087b15cc6ac3449abe88cb4119a0d03824b3642f84ff
DIST jupyter_client-8.6.3.tar.gz 342019 BLAKE2B 5a478b62d64533e334f3a01ed820f9c41ffd3a8c6d9231d4822614b32c0898af32bf67fcafb5f26a62ab7fa172880bafdf2ff1169f06e1c483e8c3fe7d3f47e6 SHA512 10d7307335d07f383acbed30e44fe92284a6eab1dccdfe9107e5390c14350c2604a11ffd4a18ff811a5a93d9ce0492ac9a2fdc0402bd324c35ca12ad22405713
diff --git a/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild b/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild
deleted file mode 100644
index ef4355759fa5..000000000000
--- a/dev-python/jupyter-client/jupyter-client-8.6.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter_client/
- https://pypi.org/project/jupyter-client/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
- ' 3.{8,9})
-"
-BDEPEND="
- test? (
- >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
- >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: times out
- tests/test_client.py::TestAsyncKernelClient::test_input_request
- # TODO
- tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o tmp_path_retention_policy=all \
- -p asyncio -p rerunfailures --reruns=3 -p timeout
-}