summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-01 04:39:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-01 05:01:19 +0200
commit333dc3fb879c26567bd93223b1fc0ea2f2ff2ab2 (patch)
treec1fa3ad4c24b6f25c27a37ae09b0399bd89894fc /dev-python/jupyter-events
parentdev-python/notebook: Bump to 7.0.1 (diff)
downloadgentoo-333dc3fb879c26567bd93223b1fc0ea2f2ff2ab2.tar.gz
gentoo-333dc3fb879c26567bd93223b1fc0ea2f2ff2ab2.tar.bz2
gentoo-333dc3fb879c26567bd93223b1fc0ea2f2ff2ab2.zip
dev-python/jupyter-events: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-events')
-rw-r--r--dev-python/jupyter-events/Manifest1
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.7.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jupyter-events/Manifest b/dev-python/jupyter-events/Manifest
index e3ded81aafe5..d61bf2f128e2 100644
--- a/dev-python/jupyter-events/Manifest
+++ b/dev-python/jupyter-events/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_events-0.5.0.tar.gz 55838 BLAKE2B a3ac815a28d2592a10394569726b76de75cb3baab0bab4c1f276da33375ba93d6bfed71fbfaca404a238b7af58ebd7e75dd7fdf6c8717141517c2f790eeb9514 SHA512 49c21f0d5dce18b137f73911b0272919a56c972561deceb228558ea369f2091ce219ac335eec002b22ca1465b2622330fb3d8973d142df4b76e350345cb6249a
DIST jupyter_events-0.6.3.tar.gz 59393 BLAKE2B 0f747cc099e8b0e30024b7fa61007d4449fad1be3b4807021df28668969dca18087634606d6f2c453da81da9c107576133e13ec373cf34362d0182320e84e809 SHA512 a9b9c180f7b4759a3d2c99421947a837020149ec1a91ad0cd06971d7ae99ad1050652f01f78c9478ce3fd3f1a1ab6b579e90c279fcee0771546f3c346becd61f
+DIST jupyter_events-0.7.0.tar.gz 59717 BLAKE2B 80ff725f4a39495ef7bf447d3bf1dcd3d7c28875c16f082788d948efec8498f01d74bb59b771537e22be7c57c0e75dd9bba70e7802262d676b531318a18d93cb SHA512 ce5ddabc4f540bfa6808319b783ad8ffcb908bc26e7435293bda4ed88221126284dfda1aafc165c8a13bdd6056ec0477915b008f4788bc19730718d4a9e3f162
diff --git a/dev-python/jupyter-events/jupyter-events-0.7.0.ebuild b/dev-python/jupyter-events/jupyter-events-0.7.0.ebuild
new file mode 100644
index 000000000000..25849717fa8e
--- /dev/null
+++ b/dev-python/jupyter-events/jupyter-events-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ dev-python/referencing[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest