summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-03 07:07:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-03 07:23:43 +0100
commit4c18e103e07776410e9f947c1a52596070a0fe21 (patch)
tree1dc13c3c9931cbb84e006cc7c9c1ce16d640bc76 /dev-python/jupyter_core
parentdev-python/coverage: Bump to 7.0.2 (diff)
downloadgentoo-4c18e103e07776410e9f947c1a52596070a0fe21.tar.gz
gentoo-4c18e103e07776410e9f947c1a52596070a0fe21.tar.bz2
gentoo-4c18e103e07776410e9f947c1a52596070a0fe21.zip
dev-python/jupyter_core: Bump to 5.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-5.1.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 616b7232a4bf..8ba1ed037793 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_core-5.0.0.tar.gz 78285 BLAKE2B 530dac61088dcbb402ffa6fd6c3e3df2238c6da438f826ddfbeb3c6f26ed4e4f0d741a2cddf801db886c24e22c74db2336e59c6223d30830a32bb38f7d7d9c3e SHA512 a587b5a0e6ceb85a842670121fe78f93a232dbdc56412c7b32b415054cf06b6028a8f4669b7e7c8a702ebbbf4873962ae4cbff2b3636f8abb75ec0ae6bdeb64d
DIST jupyter_core-5.1.0.tar.gz 80224 BLAKE2B 21eed1b69f9ab5059adf1e26eba1a30b62cf5f47976fad37b74442f2d17e0b904b89811188be526ece4b5a993de4d3cd3831d821140bf1188a0e4e0b25d11d83 SHA512 75ad0aaee5cf464d080a9dc679b5aa4b58e6d483ba53620c5a819a41fc149054ea47579d7b2903eed3de203a33a582383a384fa445a7aac7bb801029508bd914
DIST jupyter_core-5.1.1.tar.gz 81576 BLAKE2B 322d1475092e8308bc84eee3fa71b7dcfc6449cc30b5c6716dc97a71031bfc778035b1f508d5fa630ad29c373b4a2d6a2d576ed4736710c823f2a3fe383a073e SHA512 ba3075fe5ecf1130bd559646b59565bcae9649e9ef645bc3718a8c178d5e1fb5c97bdb2f6802a73245b5b3d1ab8df3f25e80e73ac0954db881ad7be8104e5a39
+DIST jupyter_core-5.1.2.tar.gz 82374 BLAKE2B aace9207d31c896017cf132f15da705118e050816123aade1602cbf9532950c8e495315d6562ce077801900d0d57adb30c66554d05bb891329cb8a59e3208375 SHA512 243a86f7f9a76dfe8a6888a287263d8bb0bab76b30d8177a2834d0767c1c3ef344317f94e223f1bb0b2b22d3c7fdece91fe313dfc20a1c90cb35393d55904c34
diff --git a/dev-python/jupyter_core/jupyter_core-5.1.2.ebuild b/dev-python/jupyter_core/jupyter_core-5.1.2.ebuild
new file mode 100644
index 000000000000..8e68f2876721
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-5.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst_parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest