summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-23 15:56:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-23 16:02:00 +0200
commit3964dc85b1077651a991f238216dbce1fba95dda (patch)
treef24d55169dd774234ae2f2a4e87b7768da4af848 /dev-python/jupyterlab-server
parentdev-python/pydantic: Bump to 2.7.1 (diff)
downloadgentoo-3964dc85b1077651a991f238216dbce1fba95dda.tar.gz
gentoo-3964dc85b1077651a991f238216dbce1fba95dda.tar.bz2
gentoo-3964dc85b1077651a991f238216dbce1fba95dda.zip
dev-python/jupyterlab-server: Bump to 2.27.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-server')
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.27.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index d236d641b392..f446fd956d42 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1,3 +1,4 @@
DIST jupyterlab_server-2.25.4.tar.gz 74772 BLAKE2B 8647840e2bb93244360db07524374f30e6831fddf6c2b89101b2a01f505470649fcc6aa31b40dc18a480628eeb791b4f7488cd91bb921796c3daad36102e535b SHA512 de04d1c5de3507a2465c316686be10ff6398be2f05d9d84ff6e79c376978503bc6ff836bfca67735d85f8ef23a15d6f30ad69268a25855dc4ebc1bd5f7c2fdaf
DIST jupyterlab_server-2.26.0.tar.gz 75100 BLAKE2B 10f507cf8b6640ee4178d2850561a5d186f9b9004b2d74de7382b4c9a03494d3553e7a2397cafb45b3be60062baf0d3df3026b1f8613e5dd2a597faad0cfc9d5 SHA512 cb9c78ae8afed53637b441767c630666d391a7ce6a19cc5cf8bcc9c3149ef570c5aeaba204878bd4d52806a6e2b9e25f9724536f1addf084bfb15855f7700125
DIST jupyterlab_server-2.27.0.tar.gz 75375 BLAKE2B c4b8c26d93a2af79ab4d82492172a8cdfb2049d7885c6cefda96f472d9edafc749c8d06ae194b5e4b66052a8514d0cbdbba1bcbc4b03fdf9e4cec65ab27cca8e SHA512 7336434b3b9378d345f7d657f8f21c3217d4605fae93a74382bb4a71135fabb3dfc7229e388737297568f13281ba9e8f710b010a6fa9b6bc0bbc5db2dd3f3293
+DIST jupyterlab_server-2.27.1.tar.gz 75524 BLAKE2B d25457954984d66ddcb52330d9a224d8e7bf85fdda7d20957a5949c95ea8d1dad0529a5135fc636911d9eef9f8663c0ef9bca71ec88f9de12cc4924b6f5ce3a5 SHA512 0ddaa2f765131357d1e75509db41a15ded720257fe956acb142e3cfb46c4cff280388b0507dead333d3c6f4cc5e6320e24be1e847c14eaf3e2f5eef0505e12c3
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.27.1.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.27.1.ebuild
new file mode 100644
index 000000000000..023800f2076e
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.27.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.19[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.18[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin -p timeout
+}