summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2020-11-01 18:38:07 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-11-05 14:32:02 +0200
commit95cf47b28d2f855fcd839b74738110667879b042 (patch)
treedfef162984e372fc136d8286bff5eea7c9c13ab1 /dev-python/ldap3
parentdev-python/kaitaistruct: Add Python 3.9 to PYTHON_COMPAT (diff)
downloadgentoo-95cf47b28d2f855fcd839b74738110667879b042.tar.gz
gentoo-95cf47b28d2f855fcd839b74738110667879b042.tar.bz2
gentoo-95cf47b28d2f855fcd839b74738110667879b042.zip
dev-python/ldap3: Bump to 2.8.1
Also add Python 3.9 to PYTHON_COMPAT. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/ldap3')
-rw-r--r--dev-python/ldap3/Manifest1
-rw-r--r--dev-python/ldap3/ldap3-2.8.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
index e30df708bb6e..43b05c8162e3 100644
--- a/dev-python/ldap3/Manifest
+++ b/dev-python/ldap3/Manifest
@@ -1 +1,2 @@
DIST ldap3-2.7.tar.gz 956927 BLAKE2B 7cc93df5b807745e6013b62bb35c281934cc7f191fe1ec2c117f23567a99d56557adfe924ad955e89326108136f9021f445a755670ab649d0ae571e0f986683a SHA512 52b9e8632a8d0b5cfdd801d165f72cfa78b6fa56e1c5e1b3b0b44ad1f1d695a55506b324d88af429319bc9b7b2a5d67d8f0eb6b7c305aa06a7ed9fec8aedbd94
+DIST ldap3-2.8.1.tar.gz 961648 BLAKE2B d6cbc52512efbe4f6fe5e7d19ee2ce1af3e03a8d6d08d2235eeff0f00c61fd12583c4b9fb452206ba161961c3438d109fa106a50a0edc858c24f5cd6261b2561 SHA512 f37e76e1008c990290285a757def6fe70e227393fbbdf84eb1130d5fdfd17db724c544848cc424ca7831f8cc9e8d25407fc139981ebd10818064f588adbafebf
diff --git a/dev-python/ldap3/ldap3-2.8.1.ebuild b/dev-python/ldap3/ldap3-2.8.1.ebuild
new file mode 100644
index 000000000000..27afe3e1be60
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="https://github.com/cannatag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+"
+# tests require a ldap server and extra configuration
+RESTRICT="test"
+
+distutils_enable_tests nose