summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-01 12:57:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-01 21:59:13 +0100
commit1674cb34a7407b3533be060fc0e6f528e05294e6 (patch)
treee0467fa6cb6bf3e74f19f398c7f442cfb4ce4840 /dev-python/lit/lit-16.0.0_pre20230101.ebuild
parentdev-python/clang-python: Add 16.0.0_pre20230101 snapshot (diff)
downloadgentoo-1674cb34a7407b3533be060fc0e6f528e05294e6.tar.gz
gentoo-1674cb34a7407b3533be060fc0e6f528e05294e6.tar.bz2
gentoo-1674cb34a7407b3533be060fc0e6f528e05294e6.zip
dev-python/lit: Add 16.0.0_pre20230101 snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit/lit-16.0.0_pre20230101.ebuild')
-rw-r--r--dev-python/lit/lit-16.0.0_pre20230101.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/lit/lit-16.0.0_pre20230101.ebuild b/dev-python/lit/lit-16.0.0_pre20230101.ebuild
new file mode 100644
index 000000000000..4950a6292b82
--- /dev/null
+++ b/dev-python/lit/lit-16.0.0_pre20230101.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}