summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-23 05:58:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-23 06:09:47 +0200
commit64c8a63ba054bbea7eac76c8da6facd9b753aa9f (patch)
tree3615a817fef86e5b89a7989c9f41f50c998f2899 /dev-python/magic-wormhole
parentdev-python/sqlglot: Bump to 17.15.0 (diff)
downloadgentoo-64c8a63ba054bbea7eac76c8da6facd9b753aa9f.tar.gz
gentoo-64c8a63ba054bbea7eac76c8da6facd9b753aa9f.tar.bz2
gentoo-64c8a63ba054bbea7eac76c8da6facd9b753aa9f.zip
dev-python/magic-wormhole: Bump to 0.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest1
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
index 95132edb3b84..07a5706deb32 100644
--- a/dev-python/magic-wormhole/Manifest
+++ b/dev-python/magic-wormhole/Manifest
@@ -1 +1,2 @@
DIST magic-wormhole-0.12.0_p20230525.gh.tar.gz 281332 BLAKE2B daf9e39c89d8591584b25f142de2e66757a31970179f38e2fb74e112295e637f94930127bd3c0c1cc1243ac559dc4885bab3e7892b112dbf174b0514b49051c0 SHA512 ef5be6396fb9d6e35c64baeeaaea269526f9f8127eaf1bdd7b7b693a0272885388c4d6dc9fac87f6355eff5e9fe94450aebeafd2009b7d74f6772922a2796cbd
+DIST magic-wormhole-0.13.0.tar.gz 274564 BLAKE2B 51752204231be0f3eac8765387386435830e91f541aaada7ca6ee52c8334879cdce68c31d40c3207a7bdb5657a5240930aedc36bab8e765f1081b20624ebdf3f SHA512 5c26da12ae94202684da14d7e3fa84ef173a31a3e5e42a40dcc2b8d3a6475943c813bcef9fbf904e419152a16e2cb4a85c2a69bbf0528f5fa63d056bf5f348e2
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
new file mode 100644
index 000000000000..43b48954d293
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.13.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="
+ https://magic-wormhole.readthedocs.io/en/latest/
+ https://github.com/magic-wormhole/magic-wormhole/
+ https://pypi.org/project/magic-wormhole/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/noiseprotocol[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
+ ~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}