summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-24 06:35:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-24 06:35:12 +0100
commit6be85a996ed2243659cd6bab11308e25d87d0d2a (patch)
treefbc14b5129e317422175ccb208dd8526d97b55e6 /dev-python/makefun
parentdev-python/mkdocs-material: Bump to 9.0.14 (diff)
downloadgentoo-6be85a996ed2243659cd6bab11308e25d87d0d2a.tar.gz
gentoo-6be85a996ed2243659cd6bab11308e25d87d0d2a.tar.bz2
gentoo-6be85a996ed2243659cd6bab11308e25d87d0d2a.zip
dev-python/makefun: Bump to 1.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/makefun')
-rw-r--r--dev-python/makefun/Manifest1
-rw-r--r--dev-python/makefun/makefun-1.15.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
index 41c56c9b88c9..9b2d634367a7 100644
--- a/dev-python/makefun/Manifest
+++ b/dev-python/makefun/Manifest
@@ -1 +1,2 @@
DIST makefun-1.15.0.tar.gz 74404 BLAKE2B b35ff14d46d50031ed42a13154c82f3fbe4105179c587dacebc0773a0d0be613e9858d57f497b8d710d7571f55230fc644592e6df67799736b37867feeb09b2e SHA512 067bd6a4176196a3aa4e96b7d460e45479cbd86d1cc611f1716fb8d1cdc17491e56f5676d7a287006ed8b80471dd28f5f48cb2eb8c1893883e3308ed9347fbae
+DIST makefun-1.15.1.tar.gz 74521 BLAKE2B e5ea20d64cebadedc63af851fd988f4b5102ea802215e87e23b5f9452bef5356f027f71853658b95caf85b6ff2c5497a8769c8e52b1d2d0c141029e1ee08bcaa SHA512 d5a43283eba61576546dbce7791825607a813658a4ef68ed6d173f8438e08f6a84027a7ce75a748e245f8dd532ca6a9eb1afa0ce795517e77b08f03c29fea034
diff --git a/dev-python/makefun/makefun-1.15.1.ebuild b/dev-python/makefun/makefun-1.15.1.ebuild
new file mode 100644
index 000000000000..a509714c5540
--- /dev/null
+++ b/dev-python/makefun/makefun-1.15.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}