summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 10:55:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 11:33:43 +0200
commit2d26b7f3ec173ee642b94bc593a656ecb2332f69 (patch)
tree519d80338e3a3eadefc11182fb1af45e66cf8004 /dev-python/manuel/manuel-1.8.0.ebuild
parentdev-python/wheel: Version Bump (diff)
downloadgentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.tar.gz
gentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.tar.bz2
gentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.zip
dev-python/manuel: Verison Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/manuel/manuel-1.8.0.ebuild')
-rw-r--r--dev-python/manuel/manuel-1.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/manuel/manuel-1.8.0.ebuild b/dev-python/manuel/manuel-1.8.0.ebuild
new file mode 100644
index 000000000000..23938d087bc5
--- /dev/null
+++ b/dev-python/manuel/manuel-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation"
+HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.python.org/pypi/manuel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( CHANGES.rst )
+
+PATCHES=( "${FILESDIR}"/${P}-rm_zope_test.patch )
+
+python_test() {
+ PYTHONPATH=src/:${PYTHONPATH} esetup.py test
+}