summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 22:00:03 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 22:00:19 +0100
commit4af7dbeb4178a823b0b999c726a58bc792384f9a (patch)
tree4117b87582c89d06ad2972691b0ecb4d7cecb68f /dev-python/mccabe/mccabe-0.4.0.ebuild
parentdev-python/flake8: Fix mccabe dep (diff)
downloadgentoo-4af7dbeb4178a823b0b999c726a58bc792384f9a.tar.gz
gentoo-4af7dbeb4178a823b0b999c726a58bc792384f9a.tar.bz2
gentoo-4af7dbeb4178a823b0b999c726a58bc792384f9a.zip
dev-python/mccabe: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/mccabe/mccabe-0.4.0.ebuild')
-rw-r--r--dev-python/mccabe/mccabe-0.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mccabe/mccabe-0.4.0.ebuild b/dev-python/mccabe/mccabe-0.4.0.ebuild
new file mode 100644
index 000000000000..1caff10459e9
--- /dev/null
+++ b/dev-python/mccabe/mccabe-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="a plugin for flake8"
+HOMEPAGE="https://github.com/flintwork/mccabe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} test_mccabe.py || die
+}