summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-25 06:00:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 06:01:56 +0100
commit6d1aa258e4e4a12127657ad70289b61cb1e93dda (patch)
treeecbb9f1d2d2c38cba29f176699b98ba1ecd30dbc /dev-python/meson-python
parentdev-python/pydantic: Remove old (diff)
downloadgentoo-6d1aa258e4e4a12127657ad70289b61cb1e93dda.tar.gz
gentoo-6d1aa258e4e4a12127657ad70289b61cb1e93dda.tar.bz2
gentoo-6d1aa258e4e4a12127657ad70289b61cb1e93dda.zip
dev-python/meson-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.12.0.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 7212b4adda2b..a34d8ec3e8c0 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,2 +1 @@
-DIST meson-python-0.12.0.gh.tar.gz 43801 BLAKE2B fa4f5b73d490fce64da5c9f79c590e32af5b39790c0ffddc694a6b11a9274760a4e92a3d45abdefdbec1e6c5235ae799ee6c3e1b99685028b3bc007d5322683d SHA512 f2e416027bb6fb6cf6ad0fd84c6b65ddc83b497ff96b5a144dfcdd1addee44972eaa7422c8d9a8092431b6df1b052f970e9e7bd7dc57b28fbf42d2ea3a8d9231
DIST meson-python-0.12.1.gh.tar.gz 43855 BLAKE2B 96b9ff5ef628bb471f7f79ce30ec6f3f851ce0006327e8b3a6003fdcb768f3280c0ee882d1c0c8ea183b0f2319d7c977c3fbb62742e3127bafb73e9732b3a1a9 SHA512 6f8e840da0155f2dd0e7139387f875cfad79eb042abcfa69b3043f51cbae3222fc2986e13798389909a0b4719513c93af381ec00a69fdfedf14bbe4e100b2f08
diff --git a/dev-python/meson-python/meson-python-0.12.0.ebuild b/dev-python/meson-python/meson-python-0.12.0.ebuild
deleted file mode 100644
index c239db438472..000000000000
--- a/dev-python/meson-python/meson-python-0.12.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Meson PEP 517 Python build backend"
-HOMEPAGE="
- https://pypi.org/project/meson-python/
- https://github.com/mesonbuild/meson-python/
-"
-SRC_URI="
- https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
- >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
- dev-util/patchelf
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' 3.8 3.9)
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.11.0-defaults.patch
-)
-
-distutils_enable_sphinx docs \
- dev-python/furo \
- dev-python/sphinx-autodoc-typehints
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires network access
- tests/test_pep518.py::test_pep518
-)
-
-src_prepare() {
- # strip dependency on ninja -- we provide ninja via Gentoo package
- # rather than the Python wheel, so we don't have .dist-info there
- sed -i -e '/ninja/d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires network access
- tests/test_pep518.py::test_pep518
- )
-
- epytest
-
- rm -rf docs/examples/spam/build/ || die # remove artifacts
-}