summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/miniupnpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/miniupnpc')
-rw-r--r--dev-python/miniupnpc/Manifest1
-rw-r--r--dev-python/miniupnpc/files/0001-Link-Python-module-against-the-shared-library.patch24
-rw-r--r--dev-python/miniupnpc/metadata.xml13
-rw-r--r--dev-python/miniupnpc/miniupnpc-1.8.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/miniupnpc/Manifest b/dev-python/miniupnpc/Manifest
new file mode 100644
index 000000000000..5cf930000730
--- /dev/null
+++ b/dev-python/miniupnpc/Manifest
@@ -0,0 +1 @@
+DIST miniupnpc-1.8.tar.gz 70624 SHA256 bc5f73c7b0056252c1888a80e6075787a1e1e9112b808f863a245483ff79859c SHA512 8eedac9ad473fc952ca8896fe534d6da6b1b234e8b6f35f721394d4c71aca84ed287ca6c4f0455b50d97a45e4cd34e27d99a6813386e0864781364aa607e13d4 WHIRLPOOL 5b76ccbb5ed7daa9bb0d481b424b7c31a5f6dc85c5c812ba10175a29aefc0d3924f3db2aa8c3529d1241be59d67d1d4c702d27aad2de8c8a07fecf3857d73169
diff --git a/dev-python/miniupnpc/files/0001-Link-Python-module-against-the-shared-library.patch b/dev-python/miniupnpc/files/0001-Link-Python-module-against-the-shared-library.patch
new file mode 100644
index 000000000000..d9e6c4317ed3
--- /dev/null
+++ b/dev-python/miniupnpc/files/0001-Link-Python-module-against-the-shared-library.patch
@@ -0,0 +1,24 @@
+From 34da047ae5b945a43430f59efe0efefdd8f1ba55 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 3 Aug 2011 08:28:31 +0200
+Subject: [PATCH] Link Python module against the shared library.
+
+---
+ setup.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index ca31f96..f5aef19 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,6 +10,6 @@ from distutils.core import setup, Extension
+ setup(name="miniupnpc", version="1.5",
+ ext_modules=[
+ Extension(name="miniupnpc", sources=["miniupnpcmodule.c"],
+- extra_objects=["libminiupnpc.a"])
++ libraries=["miniupnpc"])
+ ])
+
+--
+1.7.6
+
diff --git a/dev-python/miniupnpc/metadata.xml b/dev-python/miniupnpc/metadata.xml
new file mode 100644
index 000000000000..f38aad4d9e51
--- /dev/null
+++ b/dev-python/miniupnpc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+</maintainer>
+<maintainer>
+ <email>nikoli@gmx.us</email>
+ <name>Nikoli</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/miniupnpc/miniupnpc-1.8.ebuild b/dev-python/miniupnpc/miniupnpc-1.8.ebuild
new file mode 100644
index 000000000000..804c1f135d01
--- /dev/null
+++ b/dev-python/miniupnpc/miniupnpc-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for UPnP client library"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/miniupnpc-${PV}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Link-Python-module-against-the-shared-library.patch
+)
+
+# DOCS are installed by net-libs/miniupnpc.
+DOCS=()